Cisco路由器实现ADSL接入

作者:网络医生 发布于:2010-3-25 19:25 Thursday 分类:服务器及网络设备

 配制步聚:
*********************************************************************************************************************************


    vpdn enable
  no vpdn logging <=由于ADSL的PPPoE应用是通过虚拟拨号来实现的所以在路由器中需要使用VPDN的功能
  !
  vpdn-group pppoe <=为PPPoE启动了VPDN的进程
  request-dialin
  protocol pppoe <=设置拨号协议为PPPoE
  !
  interface FastEthernet0 <=设置公司内部网络地址
  ip address 192.168.0.1 255.255.255.0
  ip nat inside <=为启用NAT转换,设置Fast ethernet端口为内部网络,从内部网络收到的数据的原地址转换为公网地址
  !
  interface ATM0 <=设置ADSL端口
  no ip address <=请不要设置地址
  no atm ilmi-keepalive
  bundle-enable
  dsl operating-mode auto
  hold-queue 224 in
  interface ATM0.1 point-to-point <=ADSL的通讯 依靠VC,所以必须设定点到点VC
  pvc 8/35 <=设置PVC的相关参数, 即VCI和VPI的值,如果不清楚请向局端查询
  pppoe-client dial-pool-number 1 <=PPPoE拨号进程使用了常规的拨号进程,这里引用了dialer-pool 1
  !
  interface Dialer1 <=建立一个虚拟拨号端口 ip address negotiated <=由于局端提供动态地址,所以必须设定地址为协商获得
  ip mtu 1492 <=修改mtu值以适用于ADSL网络
  ip nat outside <=为启用NAT转换,设置该端口为外部网络
  encapsulation ppp <=使用PPP的帧格式
  dialer pool 1
  ppp authentication pap callin <=设置拨号的验证方式为pap
  ppp pap sent vip pass vip <=发送用户名和密码
  ip nat inside source list 1 interface Dialer1 overload
  <=设置了NAT的转换方式,使用了dialer 1端口的动态地址
  ip classless
  ip route 0.0.0.0 0.0.0.0 dialer1
  <=将所有不可路由的数据报转发给ADSL线路,设定缺省路由
  no ip http server
  !
  access-list 1 permit 10.92.1.0 0.0.0.255

********************************************************************************************************************************

Cisco 2500配制步骤:

第一步:配置vpdn
    vpdn enable(启用路由器的虚拟专用拨号网络---vpnd)
    vpdn-group office(建立一个vpdn组,)
    request-dialin(初始化一个vpnd tunnel,建立一个请求拨入的vpdn子组,)
    protocol pppoe(vpdn子组使用pppoe建立会话隧道)
第二步: 配置路由器连接adsl modem的接口
    interface Ethernet1
    no ip address
    pppoe enable允许以太接口运行pppoe
    pppoe-client dial-pool-number 1将以太接口的pppoe拨号客户端加入拨号池1
第三步:配置逻辑拨号接口:
    interface Dialer1
    ip address negotiated从adsl服务商动态协商得到ip地址
    ip nat outside为该接口启用NAT
    encapsulation ppp为该接口封装ppp协议
    dialer pool 1该接口使用1号拨号池进行拨号
    dialer-group 1该命令对于pppoe是意义不大的
    ppp authentication pap callin启用ppp pap验证
    ppp pap sent-username xxxxxxx password 0 yyyyyyy使用已经申请的用户名和口令
第四步:配置内部网络接口
    interface Ethernet0(内部网络接口)
    ip address 10.1.1.1 255.255.255.0
    ip nat inside为该接口启用NAT
第五步:配置路由器为内部网络主机提供dhcp服务
    ip dhcp excluded-address 10.1.1.1
    ip dhcp pool ABC
    import all(导入dns和wins server)
    network 10.1.1.0 255.255.255.0
    default-router 10.1.1.1
第六步:配置NAT:
    access-list 1 permit 10.1.1.0 0.0.0.255
    ip nat inside source list 1 interface Dialer1 overload
第七步:配置缺省路由
    ip route 0.0.0.0 0.0.0.0 Dialer1

 

Cisco2600配制步骤:

一、WIC-ADSL 卡接线路
vpdn enable
no vpdn logging
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
inter f0/0
ip add 192.168.0.1 255.255.255.0
ip nat inside
ip tcp adjust-mss 1450

!
inter ATM0
no ip address
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
hold-queue 224 in


interface ATM0.1 POINT-TO-POINT
pvc 8/35    此处的pvc值8/35要根据具体情况而定,咨询电信
pppoe-client dial-pool-number 1
!
inter dialer1
ip address negotiated
ip nat outside
encap ppp
dialer pool 1
ppp authen pap callin
ppp pap sent xxxx pass xxxx  用户名密码
!
ip nat inside source list 1 interface dialer1 overload
ip calssess
ip route 0.0.0.0 0.0.0.0 dialer1
no ip http server
!
access-list 1 permit 192.168.0.0 0.0.0.255


二、或者利用另外一个以太网口 接到 ADSL MODEM再接线路
hostname xxxx
ip name-server x.x.x.x  dns的地址
vpdn enable
vpdn-group pppoe
request-dialin
protocol pppoe

inter f 0/0
ip add 192.168.0.1 255.255.255.0
ip nat inside

inter f 0/1
no ip address
pppoe enable
pppoe-client dial-pool-number 1

inter dialer 1
mut 1492
ip address negotiated
ip nat outside
encap ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authen pap callin
ppp pap sent xxx pass xxx  用户名密码


ip nat inside source list 1 inter dialer 1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1 permanent
no ip http server
ip pim bidir-enable
access-list 1 permit any
dialer-list 1 protocol ip permit

 

 

 

 

标签: 思科 cisco 路由器

发表评论:

  • 9
  • 3
  • 6
  • 2
  • 7

Powered by emlog